You have this Address unreachable error when trying to ping from IPv6 VPS?
Please dont try to apply anything you read in this post, just read it quickly (if you wish) to find out solution that worked for me at the end of this post.


After we assigned IPv6 to a VPS from host server, i login to VPS command line using IPv4 and do command:
ping6 -I <VPSIPv6> <IPv6GATEWAY> (example: ping6 -I 2001:41x1:3:1f3f::5 2001:41x1:3:1f3f::1)
We should see positive reply like:
PING 2001:41x1:3:1f3f::1(2001:41x1:3:1f3f::1) from 2001:41x1:3:1f3f::5 : 56 data bytes
64 bytes from 2001:41x1:3:1f3f::1: icmp_seq=1 ttl=64 time=0.028 ms
64 bytes from 2001:41x1:3:1f3f::1: icmp_seq=2 ttl=64 time=0.053 ms
But first time i did this, i was unable to connect. I seen something like:

From 2001:41x1:3:1f3f::5 icmp_seq=3 Destination unreachable: Address unreachable
The server WAS able to ping its own gateway. but, I was not able to ping outside the gateway. (command: ping6 -I 2001:41x1:3:1f3f::6 result: From 2001:41x1:3:1f3f::1 icmp_seq=1 Destination unreachable: Address unreachable)

So, i did a command: ip -6 route show
and it did not look like there was a default ipv6 route.
So, I added this line to /etc/sysconfig/network-scripts/ifcfg-venet0


but, by adding the gateway to ifcfg-venet0 i had to change this line:


(notice the subnet change)

That change was made because after adding the route, the server could not ping its gateway (2001:41x1:3:1f3f::1) anymore.

after network restart, I was able to see a route:
default via 2001:41x1:3:1f3f::1 dev venet0 metric 1024 expires 21334360sec mtu 1500 advmss 1440 hoplimit 4294967295

I am still able to ping the gateway, but I cannot ping past the gateway.

ping6 -I 2001:41x1:3:1f3f::5
PING from 2001:41x1:3:1f3f::5 : 56 data bytes
From 2001:41x1:3:1f3f::1 icmp_seq=2 Destination unreachable: Address unreachable
From 2001:41x1:3:1f3f::1 icmp_seq=3 Destination unreachable: Address unreachable
From 2001:41x1:3:1f3f::1 icmp_seq=4 Destination unreachable: Address unreachable

(also ping6 did not worked)


1) Yes, and indeed setting a route ON HOST server, NOT on VPS was the issue in my case. Check this tutorial:
and check section "OpenVZ node IPv6 Networking configuration" of the mentioned tutorial.

2) Here some tutorial on setting routes on host openvz dedi that might help:

So this Unreachable issue might be HOST server error, not a VPS?