I tried to create OpenVZ VPS 256MB RAM plan and it failed.

tail /var/log/vzctl.log
2017-04-17T20:15:37+0000 vzctl : CT 3640 : Creating container private area (centos-6-x86)
2017-04-17T20:15:38+0000 vzctl : CT 3640 : Container is not running
2017-04-17T20:17:28+0000 vzctl : CT 3640 : Creation of container private area failed
tail /var/log/messages
Apr 17 20:15:56 host kernel: [286427.217313] VZ QUOTA: disk softlimit exceeded for id=3640
Apr 17 20:15:56 host kernel: [286427.217320] VZ QUOTA: disk quota softlimit expired for id=3640
In HyperVM:
VM creation has failed. Reason: tar var/lib/yum/history/2016-08-11/13/config-repos Wrote only 5632 of 7580 bytes tar var/lib/yum/history/2016-08-11/13/saved_tx Cannot write Disk quota exceeded tar var/lib/yum/history/2016-08-11/11 ... Exiting with failure status due to previous errors vps-create ERROR Unpack /vz/template/cache/centos-6-x86.tar.gz failed Creation of container private area failed
I tried increasing disk space in HyperVM for that Resource Plan, it not helped.
I checked used inodes used by the already setup VPS with same template (vzctl exec CTID df -i). It was way lower than inodes set for the VPS plan i was using to create VPS.

The file containing variables like diskspace, diskinodes was in my case: /etc/vz/conf/ve-vswap-256m.conf-sample

What helped to solve this OpenVZ creation issue (Disk quota exceeded) was to edit appropriate ve*.conf-sample file in /etc/vz/conf/ directory. And increase values for variable "DISKSPACE".

I had this line:
and i updated it to:

The HyperVM settings for disk space was ignored, because it seems that the VPS is first created using parameters set in ve*.conf-sample file and then HyperVM parameters are applied afterwards.