Hetzner Cloud virtual private server can install CentOS 6 and other not so standard distributions from .iso image which is available out of the box in the server administration.

Once you "mount" the iso from there, and from "Power" section do power cycling (reset), it will boot from ISO and you can use Hetzner "Console" (there is an icon in server management) to go thru the OS installation process.

Problem may be the one i had myself. Networking/SSH does not work by default.

And Ctrl key and other important characters like : and " also not worked for me (i tried US international and US default keyboard).

So how to proceed?

What worked to make networking working (in case of Hetzner cloud) was to run:
route add default gw eth0
ping started working, but i could not abort it (Ctrl+C not working) via Console so i reboot and networking again not working, so i ran that again, then SSH into the server and made that route permanent:
vi /etc/rc.local
and append:
/sbin/route add default gw eth0

unsure why "/sbin/ip route add dev eth0" not worked. Also unsure why this IP ( - i found it in "route -n" command output) and possibly on other setups and distributions can be different - check "ip route show" or "route -n"

If networking will fail in future, one can fix it via console for CentOS 6 Hetzner ISO running following commands (first replace myvpspubliciphere by your VPS public IP):
sed -i s/BOOTPROTO=dhcp/BOOTPROTO=static/g /etc/sysconfig/network-scripts/ifcfg-eth0
sed -i s/IPV6INIT=no/IPADDR=myvpspubliciphere/g /etc/sysconfig/network-scripts/ifcfg-eth0
sed -i s/ONBOOT=no/ONBOOT=yes\\nNETMASK=\\nDNS1=\\nDNS2= /etc/sysconfig/network-scripts/ifcfg-eth0
cp /etc/host.conf /etc/sysconfig/network-scripts/route-eth0
sed -i s/multi\ on/\\/32\ dev\ eth0\\ndefault\ via\\ dev\ eth0/g /etc/sysconfig/network-scripts/route-eth0
service network restart
I think it is a shame on Hetzner that they do not make any visual keyboard and allow typing | $ " ' > Ctrl key and that they do not make the networking working on ISOs so people do not need to bother with console.