To have remote desktop, one can get 1) Ubuntu server and 2) install desktop interface like Gnome, LXDE, XFCE. KDE and then 3) make the desktop available over internet thanks to software like VNCserver, x2go or NoMachine. In this tutorial is mentioned x2go setup, but you can additionally install also NoMachine which allows faster remote desktop experience than x2go.

> Another well verified tutorial for Ubuntu+LXDE is here.


Enter server terminal and run:


sudo apt-get install python-software-properties
sudo apt-get install software-properties-common
sudo add-apt-repository ppa:x2go/stable
sudo apt-get update
sudo apt-get install x2goserver x2goserver-xsession

Now graphical desktop interface, choose one, google to see how it looks:
Option A) install gnome: sudo apt-get install gnome x2gognomebindings
Option B) install XFCE: sudo apt-get install xubuntu-desktop x2gognomebindings;sudo apt-get install xfce4
Option C): install LXDE: sudo apt-get install lxde x2golxdebindings
Option D): install KDE: sudo apt-get install kubuntu-desktop plasma-widget-x2go


then in the meantime, download, install and run X2go client from

Login with X2go client

Host: your server IP
Login: your server username (maybe root)
Password: your password

some errors one may face:

1) ERROR: "Unable to execute: xfce4-session"

How to solve? i would install xfce:
sudo add-apt-repository ppa:xubuntu-dev/xfce-4.10
sudo apt-get update
sudo apt-get install xubuntu-desktop

xubuntu-desktop or xfce4

2) stdin: is not a TTY OR Connection failed mesg: ttyname failed inappropriate ioctl for device
HOW TO SOLVE? Try to open .profile or .bashrc file inside your used directory (example command: cd;vi .profile)
and lookup for line with "mesg n" and replace it by:
if `tty -s`; then
mesg n

3) host verification failed
There is a dialog, when trying to connect, try to click No instead of Yes, to update SSH key and use new one

4) it is too slow and lagging
some people advise NoMachine instead of VNC or x2go. In my case it was indeed significantly faster.