I have:
Bios: Award Modual Bios 6.00PG , P35

Make sure the flash disk is really bootable.

First solution can be to plug the USB flash disk into the USB port (try several ports on the PC) and then reboot or reset PC. Then a few seconds there is possibility to enter Bios (Del key sometimes, not Delete) or enter boot menu (F12 sometimes). So do F12 or any other key that is attached to the boot menu.

In the boot menu select USB flash disk or Hard disk.

If it do not boot from flash disk, then reboot/reset PC again and enter Bios (usually Del key, not Delete). After entering bios, set the boot order the way that USB flash disk is on the first spot. In the "Integrated peripherals" page in Bios, make sure legacy USB support is enabled. Save changes and reboot.

Here is discussion about the topic: http://forums.tweaktown.com/gigabyte/40508-unable-boot-usb-stick.html