Accessing webmin via https can encrypt login password so no one can see it in readable form while its sent from you to your server.

If you installed Webmin and you https://yourserver:10000 access dont works, then you can enable it from Webmin.

Enable HTTPS / SSL in Webmin

Login Webmin at http://yourserver:10000
Go to: Webmin / Webmin Configuration / SSL Encryption / and set "Enable SSL if available?" to Yes.

Then try accessing Webmin via HTTPS.

If not successfull, try installing this if you are on CentOS and if you wish to:

yum install openssl openssl-devel perl perl-Net-SSLeay perl-Crypt-SSLeay
or on Debian based Linux, you can try

apt-get install perl libnet-ssleay-perl openssl
Then try https:// access again making sure option "Enable SSL if available?" is set to "Yes" in Webmin.