please is there anyone who can advise which software to use to fix NTFS filesystem of the external HDD/flash drive from within Linux (ubuntu)?

I unmounted my drive so i can safely scan it using fsck:
$ sudo umount /media/lubuntu/FLASHDISK

i ran
$ sudo fsck /dev/sdb

it found dirty bit/flag, and then found some problem with MBR/MFT and i set to restore backup, but i guess it damaged the filesystem somehow, because fsck may not be compatible with ntfs which is microsoft product maybe.

$ sudo lsblk|grep sdb
sdb 8:16 1 7,5G 0 disk
$ sudo fdisk -l /dev/sdb
Disk /dev/sdb: 7,5 GiB, 8084590080 bytes, 15790215 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
$ sudo mount -t ntfs /dev/sdb /media/lubuntu/FLASHDISK
NTFS signature is missing.
Failed to mount '/dev/sdb': Nepřípustný argument
The device '/dev/sdb' doesn't seem to have a valid NTFS.
Maybe the wrong device is used? Or the whole disk instead of a
partition (e.g. /dev/sda, not /dev/sda1)? Or the other way around?
$ sudo ntfsfix /dev/sdb
Mounting volume... NTFS signature is missing.
Attempting to correct errors... NTFS signature is missing.
Failed to startup volume: Invalid argument
NTFS signature is missing.
Trying the alternate boot sector
Unrecoverable error
Volume is corrupt. You should run chkdsk.
I tried:
$ sudo testdisk /dev/sdb
but it not helped to recover it

There is also Linux tool "ntfsresize", but i have not used it as i was unable to backup the flash drive using "Disks" linux GUI app.