Advertisement: Linux VPS for $4/month - based on OpenVZ, credit card accepted, automatic setup.
+ Post New Thread
Results 1 to 2 of 2

Thread: How to run Age of Empires (AOE) on Linux?

  1. #1
    Fli is offline
    Administrator Fli's Avatar
    Join Date
    Mar 2013

    How to run Age of Empires (AOE) on Linux?

    This post is just a theory and it will probably not work, but some parts may be useful


    what are steps needed to run AOE (Age of Empires) on Linux?

    So far my first step would be to install wine:

    sudo apt-get install winehq-staging winetricks playonlinux libgl1-mesa-glx:i386 libgl1-mesa-dri:i386 libtxc-dxtn-s2tc:i386
    Without *dxtn* package, Wine may show kind of error when launching AOE:
    fixme:d3d:wined3d_dxtn_init Wine cannot find the txc_dxtn library, DXTn software support unavailable.
    It can also say:

    err:module:import_dll Library DPLAYX.dll (which is needed by L"C:\\AOE2\\Age Of Empires 2 CZ!!!!\\age2_x1.exe") not found

    err:module:LdrInitializeThunk Main exe initialization for L"C:\\AOE2\\Age Of Empires 2 CZ!!!!\\age2_x1.exe" failed, status c0000135
    There it is complaining about missing component - DIrectPlay, open "winetricks" app and "Install a Windows DLL" select DirectPlay. (maybe command "winetricks directplay" would do also)

    Then installing DirectX to play Windows games on Linux may be handy. Command:

    winetricks directx9
    Launching the Age of Empires game on Linux would be done by command "wine /full/path/to/aoedirectory/nameofthe.exe"

    I mounted AOE III .iso using Furius ISO Mount Tool and then autorun.exe launched installer, though it was unable to accept the product key saying: "Error loading the PID generator DLL"

    When i ran command "winetricks -q mfc42" and retry submitting key, it worked.

    But then the installer said: "Feature transfer error: Error: -1603 Fatal error during installation.
    Consult Windows Installer Help (Msi.chm) or MSDN for more information.

  2. #2
    Junior Member davidbarker's Avatar
    Join Date
    Jan 2019

    Is this useful / helpfull? Yes | No
    Today I wanted to play Age of Empires but it didn't work. Every time I start the game it says 'initialization failed' and closes. But the game has already worked on this pc. I'm googling for a solution online , so keep you posted.
    Last edited by davidbarker; 01-28-2019 at 10:49 AM.

+ Post New Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
 Protected by : ZB BLOCK  &  StopForumSpam