In my case this worked to play the game including my savegame profiles, though i was unable to connect TDU 1 project paradise online server (this may be just problem with my login ID or such).

I backed-up/coppied the "C:/Program Files(x86)/Atari/Test Drive Unlimited" folder and "C:/Users/me/My Documents/Test Drive Unlimited/" folders (that i had installed on Windows) to my external HDD and then used them on Linux.

On MS Windows:

1. downloaded Linux .iso image of the MX Linux from https://mxlinux.org/download-links

2. Downloaded Rufus application https://rufus.ie and launched it while i added at least 4GB USB stick/flash disk to my port. In Rufus i selected "Partition scheme" as MBR (as i have old BIOS in computer), other things i left default ticking option to format USB drive (erase all data on it) - make sure you working with correct drive, not to format wrong one. And i proceed and Rufus created Live Linux bootable flash disk.
(If you have no experience with installing operating systems (or dual boot HDD), you should backup your important data on system HDD (if there is system. If it is not, it is ok) and or disconnect non system HDDs to prevent accidentally erasing something.)

3. reboot and hit F12 and or F10 key to show boot source right after PC start. If you can not select your Linux USB as a boot source and or Windows is booting, restart againa nd hit "Del" key or other key to enter BIOS. There you may try disabling so called Secure boot and set booting order the way USB is above HDD, you may need to set it on two places.

4. Once you get to boot from Linux USB created by Rufus, you will see menu to boot into MX Linux. Once done, you can click icon to proceed with installation. If have questions, use your phone or other device to find answers on Google or such. Installation is finished and you should have dual boot system (if you had Windows or other OS installed before Linux installation). Boot into Linux.

5. In Linux, enter application called Terminal/Terminal emulator. There execute Linux commands (line after line) to install Wine (software that will help run some Windows apps including Test Drive Unlimited):

sudo apt-get update
sudo dpkg --add-architecture i386
wget -nc https://dl.winehq.org/wine-builds/Release.key
sudo apt-key add Release.key
It added: "deb https://dl.winehq.org/wine-builds/debian/ DISTRO main" into /etc/apt/sources.list.d/various.list

(!! DISTRO being either wheezy, jessie, stretch, buster or sid ... ; i used stretch, because that was what i seen when i did command "sudo apt-get update")
sudo apt-get update
sudo apt-get install --install-recommends winehq-staging

(above mentioned Wine installation steps are taken from https://wiki.winehq.org/Download)

Another useful or necessary packages for gaming on Linux, execute command:

sudo apt-get install winehq-staging, winetricks playonlinux libgl1-mesa-glx:i386 libgl1-mesa-dri:i386 libtxc-dxtn-s2tc:i386;winetricks directx9

("winetricks directx9" is command to install directX which is required by games)

6. insert TDU1 game DVD or an .iso image of the installation DVD try to launch the setup.exe. In my case setup was launched, but ended with error:
Error 1311 Source file not found: 1. Verify that the file exist and that you can access it.
console may show:
0132:fixme:ntdll:NtFsControlFile FSCTL_PIPE_IMPERSONATE: impersonating self
019b:errle:ClientRpcChannelBuffer_SendReceive called from wrong apartment, should have been 0x13100000132
019b:errle:xCall RpcChannelBuffer SendReceive failed, 8001010e
So i tried to use the .iso image file i created using some software out of my original DVD. I mounted the .iso image using Linux GUI software called Furius ISO mount tool.
It mounted the iso and i ran setup.exe from within the directory that was mounted. Setup finished
As i already ejected original DVD, i found that TDU1 do not want to launch using the shortcut that was created in my Linux menu of installed programs. But it is launching when i run Autorun.exe from the instalaltion disc/mounted iso image directory. Also it worked to launch the game when i inserted original DVD.
So the game launched without problem and i was able to play. (i seen some bug that was showing a river across the road when i was driving over it: Name:  tdu1-linux-river-over-the-road.jpg
Views: 62
Size:  39.7 KB - it is known bug https://bugs.winehq.org/show_bug.cgi?id=28196 that should have been fixed in Wine 4.8).
It also happened that game locked my linux workspace somehow so i have to restart computer.

7. if game is working, you can proceed to copy your TDU1 savegame data (on Window usually located in C:/Users/username/My Documents/Test Drive Unlimited/) to be in your Linux documents path, example in my case path is like this: /home/mylinuxusername/Documents/Test Drive Unlimited/savegame/mytduusername/ (you can backup, rename original savegame folder just in case)

8. To install project paradise launcher, download it from the website (https://forum.turboduck.net/threads/...ailable.29561/ ; http://y0b.net/tdu_client.zip). Extract archive "tdu_client.zip" contents, read extracted "ReadMe.txt" file which instructs to copy extracted file "d3d9.dll" to TDU directory, in my case /home/MYUSERNAME/.wine/drive_c/Program Files (x86)/Atari/Test Drive Unlimited/
(Note that installation of the 1.66A & Car megapack patches caused game to stop launching, so i do not recommend installing it - i had to revert it by replacing ....wine/drive_c/Program Files (x86)/Atari/Test Drive Unlimited/TestDriveUnlimited.exe file by one i backed up on my Windows PC.)

I double click extracted "TDU - Project Paradise Launcher.exe" and browse to the above mentioned path to select TestDriveUnlimited.exe and click "Start".
After several seconds, game was launched, but it shows bad game window proportions. So i quit (erasing key and enter key) and start launcher again selecting "Windowed" mode in the launcher. It worked. But connecting to online server fails for me when using GameSpy and my login credentials: Failed to connect to the TEST DRIVE Server. Please check your network status and try again.
Login credentials use valid old ones, follow ReadMe.txt of the project paradise archive.
If you fail to login, you may try to just enter your username (the one that match folder name in ...Documents/Test Drive Unlimited/savegame/) and tick the GameSpy tickbox. No e-mail, password.

Game may not start for various reasons. Best is to copy and google the errors. Maybe one can get error "002c:err:d3d:wined3d_resource_allocate_sysmem Failed to allocate system memory." But i do not know the cause.

-----------------
Following lines are there just for a backup, do not follow them.

6. insert Test Drive Unlimited DVD into computer or use .iso image of the TDU1 disc that you will mount as a directory. I had .iso (some can be certainly found on the internet) and i mounted my .iso like this:
(1) i find full path to my .iso (in my case: /media/me/88B8-AC7A/tdu1my.iso)
(2) then i created new directory called "tdudisk" on a HDD where is 4GB+ disk space (in my case path of this dir: /media/me/DATA/tdudisk/)
(3) then i mounted my .iso to the directory i created: mount -o loop /media/me/88B8-AC7A/tdu1my.iso /media/me/DATA/tdudisk/
(4) now i go to the tdudisk directory by executing command: cd /media/me/DATA/tdudisk/
(5) then i list contents to see Autorun.exe and others, good, i try to launch installer by command: wine /media/me/DATA/ISOs/Autorun.exe

----